const regex = /'([^']*(?:''[^']*)*)'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'([^\']*(?:\'\'[^\']*)*)\'', 'g')
const str = `'word'''',and''','another'',''word','''test',X,'',FUNCTION('A'' B C D')`;
const subst = `\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);