import Foundation
let pattern = #"'([^']*(?:''[^']*)*)'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"'word'''',and''','another'',''word','''test',X,'',FUNCTION('A'' B C D')"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)