use strict;
my $str = '\'word\'\'\'\',and\'\'\',\'another\'\',\'\'word\',\'\'\'test\',X,\'\',FUNCTION(\'A\'\' B C D\')';
my $regex = qr/'([^']*(?:''[^']*)*)'/p;
my $subst = '\\0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";