#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "'([^']*(?:''[^']*)*)'"
Local $sString = "'word'''',and''','another'',''word','''test',X,'',FUNCTION('A'' B C D')"
Local $sSubst = "\0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)