re = /'([^']*(?:''[^']*)*)'/
str = '\'word\'\'\'\',and\'\'\',\'another\'\',\'\'word\',\'\'\'test\',X,\'\',FUNCTION(\'A\'\' B C D\')'
subst = '\\0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result