using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'([^']*(?:''[^']*)*)'";
string substitution = @"\0";
string input = @"'word'''',and''','another'',''word','''test',X,'',FUNCTION('A'' B C D')";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}