$re = '/\'([^\']*(?:\'\'[^\']*)*)\'/';
$str = '\'word\'\'\'\',and\'\'\',\'another\'\',\'\'word\',\'\'\'test\',X,\'\',FUNCTION(\'A\'\' B C D\')';
$subst = "\0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;