# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(images\/)(*SKIP)(*F)|([^\/]*)\//$1$2-/g;t' <<< "images/Qcuj/lXOSWNDwF/FmSgCbQ==.jpg"