use strict;
my $str = 'images/Qcuj/lXOSWNDwF/FmSgCbQ==.jpg';
my $regex = qr~(images/)(*SKIP)(*F)|([^/]*)/~p;
my $subst = '$1$2-';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";