re = /(images\/)(*SKIP)(*F)|([^\/]*)\//
str = 'images/Qcuj/lXOSWNDwF/FmSgCbQ==.jpg'
subst = '$1$2-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result