using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(images/)(*SKIP)(*F)|([^/]*)/";
string substitution = @"$1$2-";
string input = @"images/Qcuj/lXOSWNDwF/FmSgCbQ==.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}