#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<div.*?class="moz-widget-id"[^>]*>)(.*?)(<\/div>)"
Local $sString = "<div class="row">" & @CRLF & _
" <div class="column col-md-4 col-sm-4 col-xs-4">" & @CRLF & _
" <!--moz-module-->" & @CRLF & _
" <div class="moz-widget">" & @CRLF & _
" <div class="moz-widget-id">[moz_widget]googlemaps[\/moz_widget]</div>" & @CRLF & _
" </div>" & @CRLF & _
" <!--/moz-module-->" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div class="column col-md-4 col-sm-4 col-xs-4">" & @CRLF & _
" <!--moz-module-->" & @CRLF & _
" <div class="moz-widget">" & @CRLF & _
" <div class="moz-widget-id">[moz_widget]socialicons[\/moz_widget]</div>" & @CRLF & _
" </div>" & @CRLF & _
" <!--/moz-module-->" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" <div class="column col-md-4 col-sm-4 col-xs-4">" & @CRLF & _
" <!--moz-module-->" & @CRLF & _
" <div class="moz-widget">" & @CRLF & _
" <div class="moz-widget-id">[moz_widget]callaction[\/moz_widget]</div>" & @CRLF & _
" </div>" & @CRLF & _
" <!--/moz-module-->" & @CRLF & _
" </div>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")