use strict;
my $str = '<div class="row">
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]googlemaps[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]socialicons[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]callaction[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
</div>';
my $regex = qr/(<div.*?class="moz-widget-id"[^>]*>)(.*?)(<\/div>)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}