import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<div.*?class=\"moz-widget-id\"[^>]*>)(.*?)(<\\/div>)";
final String string = "<div class=\"row\">\n"
+ " <div class=\"column col-md-4 col-sm-4 col-xs-4\">\n"
+ " <!--moz-module-->\n"
+ " <div class=\"moz-widget\">\n"
+ " <div class=\"moz-widget-id\">[moz_widget]googlemaps[\\/moz_widget]</div>\n"
+ " </div>\n"
+ " <!--/moz-module-->\n"
+ " </div>\n\n"
+ " <div class=\"column col-md-4 col-sm-4 col-xs-4\">\n"
+ " <!--moz-module-->\n"
+ " <div class=\"moz-widget\">\n"
+ " <div class=\"moz-widget-id\">[moz_widget]socialicons[\\/moz_widget]</div>\n"
+ " </div>\n"
+ " <!--/moz-module-->\n"
+ " </div>\n\n"
+ " <div class=\"column col-md-4 col-sm-4 col-xs-4\">\n"
+ " <!--moz-module-->\n"
+ " <div class=\"moz-widget\">\n"
+ " <div class=\"moz-widget-id\">[moz_widget]callaction[\\/moz_widget]</div>\n"
+ " </div>\n"
+ " <!--/moz-module-->\n"
+ " </div>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}