// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<div.*?class="moz-widget-id"[^>]*>)(.*?)(<\/div>)"#).unwrap();
let string = "<div class=\"row\">
<div class=\"column col-md-4 col-sm-4 col-xs-4\">
<!--moz-module-->
<div class=\"moz-widget\">
<div class=\"moz-widget-id\">[moz_widget]googlemaps[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class=\"column col-md-4 col-sm-4 col-xs-4\">
<!--moz-module-->
<div class=\"moz-widget\">
<div class=\"moz-widget-id\">[moz_widget]socialicons[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class=\"column col-md-4 col-sm-4 col-xs-4\">
<!--moz-module-->
<div class=\"moz-widget\">
<div class=\"moz-widget-id\">[moz_widget]callaction[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
</div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}