using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<div.*?class=""moz-widget-id""[^>]*>)(.*?)(<\/div>)";
string input = @"<div class=""row"">
<div class=""column col-md-4 col-sm-4 col-xs-4"">
<!--moz-module-->
<div class=""moz-widget"">
<div class=""moz-widget-id"">[moz_widget]googlemaps[\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class=""column col-md-4 col-sm-4 col-xs-4"">
<!--moz-module-->
<div class=""moz-widget"">
<div class=""moz-widget-id"">[moz_widget]socialicons[\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class=""column col-md-4 col-sm-4 col-xs-4"">
<!--moz-module-->
<div class=""moz-widget"">
<div class=""moz-widget-id"">[moz_widget]callaction[\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
</div>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}