re = /(<div.*?class="moz-widget-id"[^>]*>)(.*?)(<\/div>)/
str = '<div class="row">
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]googlemaps[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]socialicons[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]callaction[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end