import Foundation
let pattern = #"(<div.*?class="moz-widget-id"[^>]*>)(.*?)(<\/div>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="row">
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]googlemaps[\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]socialicons[\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]callaction[\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}