const regex = /(<div.*?class="moz-widget-id"[^>]*>)(.*?)(<\/div>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<div.*?class="moz-widget-id"[^>]*>)(.*?)(<\\\/div>)', '')
const str = `<div class="row">
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]googlemaps[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]socialicons[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
<div class="column col-md-4 col-sm-4 col-xs-4">
<!--moz-module-->
<div class="moz-widget">
<div class="moz-widget-id">[moz_widget]callaction[\\/moz_widget]</div>
</div>
<!--/moz-module-->
</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}