# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<div.*?class=\"moz-widget-id\"[^>]*>)(.*?)(<\/div>)"
test_str = ("<div class=\"row\">\n"
" <div class=\"column col-md-4 col-sm-4 col-xs-4\">\n"
" <!--moz-module-->\n"
" <div class=\"moz-widget\">\n"
" <div class=\"moz-widget-id\">[moz_widget]googlemaps[\\/moz_widget]</div>\n"
" </div>\n"
" <!--/moz-module-->\n"
" </div>\n\n"
" <div class=\"column col-md-4 col-sm-4 col-xs-4\">\n"
" <!--moz-module-->\n"
" <div class=\"moz-widget\">\n"
" <div class=\"moz-widget-id\">[moz_widget]socialicons[\\/moz_widget]</div>\n"
" </div>\n"
" <!--/moz-module-->\n"
" </div>\n\n"
" <div class=\"column col-md-4 col-sm-4 col-xs-4\">\n"
" <!--moz-module-->\n"
" <div class=\"moz-widget\">\n"
" <div class=\"moz-widget-id\">[moz_widget]callaction[\\/moz_widget]</div>\n"
" </div>\n"
" <!--/moz-module-->\n"
" </div>\n"
" </div>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.