import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z0-9&\\'\\\" +]";
final String string = "Integrated Eligibility System, Enrollment, Case Management System, EECM Solution Design, Medical Assistance Program, dig\n"
+ "ital, client self-service and delivery channel en\n"
+ "hancements, data sharing, reporting, analytics Technology";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}