# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/split(",")//g;t' <<< "/text word1, word2, some_other_word, word_4"