use strict;
my $str = '/text word1, word2, some_other_word, word_4';
my $regex = qr/split(",")/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";