# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*(\d{3}\.\d+\.\d+\.\d+).*$/$1/s;t' <<< "Lorem ipsum dolor sit amet
consectetur adipisicing elit
IP: 284.283.47.9
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua."