using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(\d{3}\.\d+\.\d+\.\d+).*$";
string substitution = @"$1";
string input = @"Lorem ipsum dolor sit amet
consectetur adipisicing elit
IP: 284.283.47.9
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua.";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}