#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^.*(\d{3}\.\d+\.\d+\.\d+).*$"
Local $sString = "Lorem ipsum dolor sit amet" & @CRLF & _
"consectetur adipisicing elit" & @CRLF & _
"IP: 284.283.47.9" & @CRLF & _
"sed do eiusmod tempor incididunt" & @CRLF & _
"ut labore et dolore magna aliqua."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)