import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(\\d{3}\\.\\d+\\.\\d+\\.\\d+).*$";
final String string = "Lorem ipsum dolor sit amet\n"
+ "consectetur adipisicing elit\n"
+ "IP: 284.283.47.9\n"
+ "sed do eiusmod tempor incididunt\n"
+ "ut labore et dolore magna aliqua.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}