re = /^.*(\d{3}\.\d+\.\d+\.\d+).*$/
str = 'Lorem ipsum dolor sit amet
consectetur adipisicing elit
IP: 284.283.47.9
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua.'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result