const regex = /^.*(\d{3}\.\d+\.\d+\.\d+).*$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(\\d{3}\\.\\d+\\.\\d+\\.\\d+).*$', 's')
const str = `Lorem ipsum dolor sit amet
consectetur adipisicing elit
IP: 284.283.47.9
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);