package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^.*(\d{3}\.\d+\.\d+\.\d+).*$`)
var str = []byte(`Lorem ipsum dolor sit amet
consectetur adipisicing elit
IP: 284.283.47.9
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua.`)
var substitution = []byte("$1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}