# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*(\d{3}\.\d+\.\d+\.\d+).*$"
test_str = ("Lorem ipsum dolor sit amet\n"
"consectetur adipisicing elit\n"
"IP: 284.283.47.9\n"
"sed do eiusmod tempor incididunt\n"
"ut labore et dolore magna aliqua.")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.