import Foundation
let pattern = #"^.*(\d{3}\.\d+\.\d+\.\d+).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
Lorem ipsum dolor sit amet
consectetur adipisicing elit
IP: 284.283.47.9
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}