package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w+\s#(\d+)`)
var str = []byte(`Incident #00028327 Is now Assigned to Developers Queue`)
var substitution = []byte("(REF:IN:\1)")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}