re = /^\w+\s#(\d+)/
str = 'Incident #00028327 Is now Assigned to Developers Queue'
subst = '(REF:IN:\\1)'
result = str.sub(re, subst)
# Print the result of the substitution
puts result