// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)^\w+\s#(\d+)").unwrap();
let string = "Incident #00028327 Is now Assigned to Developers Queue";
let substitution = "(REF:IN:\\1)";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}