import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"^\w+\s#(\d+)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"Incident #00028327 Is now Assigned to Developers Queue"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"(REF:IN:\1)"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}