use strict;
my $str = 'Incident #00028327 Is now Assigned to Developers Queue';
my $regex = qr/^\w+\s#(\d+)/up;
my $subst = '(REF:IN:\\1)';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";