$re = '/^\w+\s#(\d+)/u';
$str = 'Incident #00028327 Is now Assigned to Developers Queue';
$subst = "(REF:IN:\1)";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;