#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$"
Local $sString = "+000099,8420000"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)