$re = '/^\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$/';
$str = '+000099,8420000';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;