use strict;
my $str = '+000099,8420000';
my $regex = qr/^\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$/p;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";