re = /^\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$/
str = '+000099,8420000'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result