using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+?(-?)0*([[:digit:]]+,[[:digit:]]+?)0*$";
string substitution = @"\1\2";
string input = @"+000099,8420000";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}