package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<fileName>)(.+)?(<\/fileName>)`)
var str = ` <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<segments>0000</segments>
</file>`
var substitution = "\1[!] value does not exist!\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}