use strict;
my $str = ' <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<segments>0000</segments>
</file>';
my $regex = qr/(<fileName>)(.+)?(<\/fileName>)/mp;
my $subst = '\\1[!] value does not exist!\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";