import re
regex = re.compile(r"(<fileName>)(.+)?(<\/fileName>)", flags=re.MULTILINE)
test_str = (" <file> \n"
" <fileType>Mezza</fileType>\n"
" <fileName></fileName>\n"
" <segments>0000</segments>\n"
" </file>")
subst = "\\1[!] value does not exist!\\3"
result = regex.sub(subst, test_str)
if result:
print(result)