re = /(<fileName>)(.+)?(<\/fileName>)/m
str = ' <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<segments>0000</segments>
</file>'
subst = '\\1[!] value does not exist!\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result