# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*"|aziShift=.*\)/AAAAAAAAAAAAAAAAAAAAAA/gm;t' <<< " redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,
gridTable=ModelicaServices.ExternalReferences.loadResource(\"modelica://AllHouses/Resources/grids/tables.txt\"),
weatherFile=ModelicaServices.ExternalReferences.loadResource(\"modelica://AllHouses/Resources/weatherdata/Uccle.TMY\"),
redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,
redeclare AllHouses.Submodels.Heating.FloorHeating heating,
redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,
sim(aziShift=0));"