// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*"|aziShift=.*\)"#).unwrap();
let string = " redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,
gridTable=ModelicaServices.ExternalReferences.loadResource(\"modelica://AllHouses/Resources/grids/tables.txt\"),
weatherFile=ModelicaServices.ExternalReferences.loadResource(\"modelica://AllHouses/Resources/weatherdata/Uccle.TMY\"),
redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,
redeclare AllHouses.Submodels.Heating.FloorHeating heating,
redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,
sim(aziShift=0));";
let substitution = "AAAAAAAAAAAAAAAAAAAAAA";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}