re = /BuildingEnvelope.* |Heating.* |Ventilation.* |Occupancy.* |weatherdata.*"|aziShift=.*\)/m
str = ' redeclare AllHouses.Submodels.Ventilation.Ventilation ventilation,
gridTable=ModelicaServices.ExternalReferences.loadResource("modelica://AllHouses/Resources/grids/tables.txt"),
weatherFile=ModelicaServices.ExternalReferences.loadResource("modelica://AllHouses/Resources/weatherdata/Uccle.TMY"),
redeclare AllHouses.Submodels.BuildingEnvelope.VLA2 buildingEnvelope,
redeclare AllHouses.Submodels.Heating.FloorHeating heating,
redeclare AllHouses.Submodels.Occupancy.Occupancy occupancy,
sim(aziShift=0));'
subst = 'AAAAAAAAAAAAAAAAAAAAAA'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result